About Mac OS 10.6 support

Follow

Due to recent Xcode update (to Xcode 6.1), to make sure we could roll in more new and innovative features, Snow Leopard Mac OS 10.6 will no longer be supported to install Splashtop client and Streamer; which means, users will not be able to establish remote connections with those Macs still running Mac OS 10.6 using Splashtop Business v2.6.5.2, Splashtop Personal v2.6.4.1 and Streamer v2.6.2.7, or later version.

We recommend that you could upgrade Mac OS 10.6 to Yosemite, you are able to do it for free in some cases (http://www.apple.com/osx/how-to-upgrade/). If for some reason, you still have to stay with Mac OS 10.6, we also provide the last Mac OS 10.6 supported version Splashtop Business and Streamer here, they are:

  • Splashtop Business 2.6.0.5: link.
  • Splashtop Personal 2.6.2.2: link.
  • Streamer 2.6.2.3: link.
  • Streamer 2.6.2.3 deployment version: link.

Sorry for any inconvenience caused, and please leave your comment here or file a ticket if there is any question.

 

Have more questions? Submit a request