Connection Request Dialog Box non-modal

 why is the connection request limited to 10 seconds, and dialog box is hidden behind all windows?

would like to change to at least 20 seconds, and modal window that shows up in the foreground over ALL windows.  

 

 

 

 

0

Comments

7 comments
  • > why is the connection request limited to 10 seconds

    We need to tweak the protocol a bit to allow longer (and user-settable) timeout values. We're working on this!

    > dialog box is hidden behind all windows

    We just tried it out, since it seems to always work for us.

    What we observed just now is this: dialog box stays behind IF (1) streamer window is open AND (2) streamer window is behind certain apps (CMD window will block it; Chrome won't...mysteriously enough).

    If streamer window is not open, then dialog box always comes up to front.

    If foreground window is Chrome (for example), then dialog box always comes up front regardless of whether streamer window is open or not.

    We'll investigate and improve.

    Thanks,
    Phil

    0
    Comment actions Permalink
  • i'm all for user defined settings, but for the inexperienced user running this the first time the value of 10 seconds is not sufficient unless you can guarantee that dialog box is sent to the foreground.    Is this confirmation connection dialog box now the default setting with SplashTopSos.exe? I don't recall this in past remote connections?

     

     

     

     

     

     

    0
    Comment actions Permalink
  • We'll probably increase the default to a larger value. (10 sec is the max possible right now until we re-do the protocol.)

    The SOS app has a "Settings" menu where user can choose whether or not to require permission. (Default is NOT.) Once checked, the user's preference is remembered, for user's future convenience.

    If the user deletes the SOS app and downloads it again, the box will remain checked. He can go uncheck the box anytime, and that change will be remembered as well.

    Phil

    0
    Comment actions Permalink
  • ok thank you, that makes sense. The user turned that option on before we attempted to the connection.   I tried Chrome in the foreground, but the dialog did not appear in front.   Might want to also play a sound / ding when the dialog appears.

     

     

     

     

     

    0
    Comment actions Permalink
  • Cool. Thanks for the suggestions!

    0
    Comment actions Permalink
  • Was this problem resolved in a new update? Also i noticed subscription pricing has doubled for this service.  I didn't lock in the reduced yearly rate while beta testing this.  Is this rate still offered to those who were still testing the software? Thanks

     

    0
    Comment actions Permalink
  • @Faxsupport,

    The issue should have been fixed in next version of the streamer. We will also adjust the waiting timer to 30 seconds in the same streamer.

    For the pricing model, now SOS is mobile devices supported thus the pricing model change. For old SOS subscribed users, you can keep your term.

    Hope this helps.

    Thanks,
    Vans

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post