Display flickering when connectiong to remote pc


I use splashtop business to work from home on my office pc. 

Since a few weeks when I connect to my work pc the main monitor display start flickering. I cannot use the screen, it's just frozen. I have two monitors at the office and at home. When I change to multiple monitors on multiple windows the second monitor pops up and works fine. ICT from my company and me can't seem to find what is causing this. We tried updating everything and reinstalling splashtop but nothing seems to fix it. 


Anyone a suggestion to fix this problem?



  • Hi, I have been having the same issue for quite some time now. Every time a pop ups occurs in the remote computer; the screen starts flashing and the only solution is to close the connection and connect back again. This is really annoying. I sent a message to Tech Support and they wanted a video of that. I never had a reply from them.

  • I'm the IT guy. one of the users complained about the same issue. dual screen and the main screen is flickering. we did an uninstall on the streamer and the business app. same issue. I noticed that when I disconnected the streamer. the business app is reconnecting and it's stilling flickering the screen which suggest the issue is on the business app side

  • Same flickering issue mentioned above. I have two monitors at work and when I connect via my laptop one of the screens will flicker and be unresponsive. I switch to a single screen, then have to close the connection and actually terminate Splashtop business, launch it and try again. This usually fixes the problem if one screen is loaded, however when I switch to multiple screens the same flickering issue will happen sometimes.

    When it is working normally the flickering will also start if Windows has to ask my permission to open a file or run a program. I then have to terminate Splashtop business and hope the flickering goes away the next time I connect.

    This is getting annoying. Please come up with a solution. Thanks

    Splashtop Streamer v3.5.2.3

    Splashtop Business v3.5.2.4

  • Hi everyone, 

    I contacted Tech Support, and this is what they asked me to do:

    In the Business App, disconnect from any computer, then do the following:

     Goto File --> Options --> Advanced Tab and enable "Use legacy compatible mode"

    So far, I have not seen the issue, but it is too soon to be sure. I will keep you all posted.

    Splashtop Business v3.5.2.4

  • Thanks @Frank Padron!

     Goto File --> Options --> Advanced Tab and enable "Use legacy compatible mode"

    That did the trick. Flickering doesn't even occur when Windows has to ask my permission to open a file. I can finally work again without all this flickering anxiety! Now hopefully it stays this way.

  • Glad it help you. Of course, this is just a patch and I hope they fix this bug soon because making that change degrades the performance a little bit.

  • Thank you @Frank Padron!


    Worked for me too, support suggested the same thing.

  • Same problem here. Thanks to @Frank Padron for the suggestion.  I hope Splashtop engineers are on this... it needs sorting yesterday!!!


Please sign in to leave a comment.

Didn't find what you were looking for?

New post