Splashtop Account settings do not persist across different users.

Hello,

 

 I am trying to use Splashtop business for Remote Assistance. My issue is that the Splashtop Account settings in Splashtop streamer do not persist between different users. 

 

Example : I set up Splastop streamer on a workstation with my account. And everything works fine. I log out and a user logs in to the machine. Splashtop streamer disconnects and forgets the Splashtop account information. I can not remotely assist the user. 

 

Is there a way to set up the Splashtop Streamer so that the Splashtop account settings persist no matter which user logs in to the machnine?

 

Kevin Stone

 

10

Comments

14 comments
  • I´m trying Splashtop for Business and also had the same problem. If there is no solution I won´t buy it...

    0
    Comment actions Permalink
  • Oh wow, that is indeed a problem if that is the case. It shouldn't be based on any users being logged in. It should be a service that is always running with the same settings. This could be bad and definitely needs to be fixed.

    0
    Comment actions Permalink
  • I have the same issue. I also won't purchase this product if that's the case. I have multiple users that need to access the same machine concurrently. Does each user need to have their own splash top account?

    0
    Comment actions Permalink
  • I have noticed the same problem while I am trying Business version as well. After logging into each account and logging with the streamer the problem went away. An update to resolve this in future would be great.

    0
    Comment actions Permalink
  • Yeah.. I really liked this product at first but the fact that when I log out a user so I can log in as Administrator typically results in the PC becoming unreachable...I I may have to look at a different product.  I've opened a ticket with Support an they say that the 'temporary loss of connection is normal" but I have NEVER used another product that doesn't stay connected throughout multiple log outs / ins with different user names.   This is so annoying.  Just now remoted to PC, clicked Login...get purple screen "please wait, logging in" and now the PC is unreachable.  (Yes the network is up because I can see the other PC's at that site and I remoted another one, used the logged in user, and pinged the PC I was trying to support.  Ended up having to use RDP from another PC to support this user.  This is not acceptable. 

    0
    Comment actions Permalink
  • Besides the lack of a stable connectivity situation between users, I see a security issue here.  

    Specifically, any user who can login to a system (even a non-admin user) can enable any arbitrary outsider to access his login session using splashtop.  Access to the login session then means access to anything on the local network which that user may have rights to access.  As a network administrator, I'd like to control who gets the keys to the network.  I'd like to avoid giving users the rights to open the network to anyone else.

    0
    Comment actions Permalink
  • Yea Mark but usually for business purposes people sign up for an account to monitor other machines for clients etc...  EX: The account that is attached to splashtop is an administrator account...  In my mind, splashtop should check the user's groups at the time of entering in the splashtop user/pass.  If that user (whoever they are) has admins rights then splashtop should use that info for EVERYONE who logs in.  If that user does not have admin rights then the current results should be expected.

    In my case this "FLAW" is not acceptable.  There should be some type of workaround.  Especially for the BUSINESS version.  Personal version I could understand.  But how does one remote support a machine that has more then one user???

    0
    Comment actions Permalink
  • I spoke to someone at Splashtop last week.  They said that these issues should all be addressed in a new release of the Business product which 'should' get out sometime in the next couple of weeks.

     

    I'm waiting to see a difference.

    0
    Comment actions Permalink
  • Hi All,

    The current version of Splashtop Business provides a "deployable streamer" from your my.splashtop.com login.  This streamer will persist across all accounts on the computer.  Please try this out.  You should have also received an email pointing out this new functionality.

    0
    Comment actions Permalink
  • Settings seem to persist across accounts - but why do I get kicked out every time I log off a user (to login as another).  To make matters more difficult, I have to wait up to 5 minutes before I can successfully reconnect to log back in (as the other user).   The software should allow me to go directly to the login screen. I know it's doable - LogMeIn and TeamViewer both can.

    0
    Comment actions Permalink
  • This is still a very annoying issue.  Everyone I switch user or log off a user to log on as another, it boots me out and I have to re-enter credentials.  Often it will accept credentials and then immediately lock again.  Once I enter credentials yet again, it will finally let me in and work fine until I have to switch users again.  Please find a way to stabilize this, as it makes it very challenging and fairly embarrassing when remoting into a computer where a user is there and watching me enter passwords continually...

    0
    Comment actions Permalink
  • @Mrcomputer & Glen,

    Please join our beta test for new Streamer which could improve the behavior you mentioned. You could refer to https://support-splashtopbusiness.splashtop.com/entries/62163074 for more details.

    0
    Comment actions Permalink
  • i experienced the same issue and cannot connect back.  Installed splashtop under VNC connection, logged into Splashtop, tried to switch user and cannot connect back to the system at all.  Asking user to reboot and hope it solves the problem.  Need to switch profiles because this is a shared computer.

    Thanks!

    0
    Comment actions Permalink
  • @Rick.Cassel,

    This should not happen using v3 streamer. Does it constantly happen? Could you please remove the streamer then re-install it again then see if the issue is still there?

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post