Completed

Splashtop Business for linux

Hi Guys

We badly need splashtop business for linux, I admin most of my clients from linux using a mixture of VNC and splashtop. If there was business for linux I could do away with VNC altogether.

 

Regards Mike Simmons

19

Comments

29 comments
  • Official comment
    Comment actions Permalink
  • I subscribe to the Business version of Splashtop and I would find it helpful to support Linux systems from a Windows or Linux environment. My main system is windows but I have Ubuntu 14.04 on my laptop and would find it helpful to remote support from the Ubuntu 14.04 based Laptop.

    I've found many old but still useful systems can be deployed for customers who need to get off the Expired XP platform. I usually install Peppermint Linux which has proven to be a very good light weight distro based on the LTS version of Ubuntu 14.04.

    Having a streamer for 14.04 would be helpful and even more so if I'm sitting at my Linux workstation and could remote support windows and Linux systems.

    I'm  a small time one man show and Splashtop has greatly helped.

    Thanks

    1
    Comment actions Permalink
  • We desperately need a linux client.

    I somehow got lucky and had the Windows Splashtop client running in Wine on Ubuntu 12.04.  I upgraded to 14.04 a few days ago and now it no longer works.  I'm a few hours into playing with Wine and still no luck.  I think I'm screwed and don't know what I'm going to do.  :-(

    1
    Comment actions Permalink
  • Please, make a Business Linux Client!! It's not far from what you already have, as the actual Personal Linux client works very well!

    1
    Comment actions Permalink
  • Any news on a Linux streamer (for access via Splashtop-Business client on Windows and Android?

    0
    Comment actions Permalink
  • My company is moving to Linux servers and thus has started providing IT staff with Linux laptops.  They do not understand why Splashtop does not offer a native Linux client for business (or personal).  We have heavily relied on remote control software over the years - beginning with PC Anywhere, then RAdmin, to TightVNC, LogMeIn, and a very brief time with TeamViewer, and now with Splashtop.  Over the years, the client applications became slow and bloated or the proce got too high.  We have been very happy with splashtop windows, but now may be force to switch to NoMachine NX.  The fact that there was a client for Ubuntu Linux 12.04 only makes the position you've taken even more frustrating.

    0
    Comment actions Permalink
  • @Bwdavis & all,

    We suggest that you could use Chrome app on your Linux platform for now, it will work. (It might not work with Chromium.)

    0
    Comment actions Permalink
  • Any news ? We can't access to Linux PC (even with Chrome app installed).

    0
    Comment actions Permalink
  • @Mistral,

    Is there any error message? Could we know more details about the issue you saw?

    0
    Comment actions Permalink
  • I think that Im a victim of false advertising,  no linux support.  #trialisover

    0
    Comment actions Permalink
  • The suggested Chrome App is unreliable. I've been dealing with many problems with it. Sometimes speed is very bad (normal on Windows client), sometimes specific UI elements becomes unclickable. Waiting my 1 year subscription to end and them migrate to other service.

    0
    Comment actions Permalink
  • I've tried the chrome app and it asks for password but it doesnt get connected, I just renewed my year subscription and its going to be my last.

    0
    Comment actions Permalink
  • @Info,

    It is the Windows log-in password or the Chrome app log-in password? Could I have a screenshot of the window and the error so I could have more clues address the issue? Thank you.

    0
    Comment actions Permalink
  • I just signed up for the trial to see if this will work for us.  We use linux laptops and connect to Windows servers.

    The chrome app works but it is sooooo slow.  Unusable really.  Windows client is fast.  And it fails in virtualbox due to missing 3D.

    Is there anything we can tweak or is this product a no go for linux support admins?

    0
    Comment actions Permalink
  • @Mwhite, I wasn't able at all to make this work fine to access Windows Server machines from Linux, which I also use as primary desktop. Had always the same issue, very slow work, unusable. I quit trying to use Splashtop after a year of subscription and lots of trouble, gone to TeamViewer integrated into GFI Max Focus RMM solution.

    0
    Comment actions Permalink
  • Are there plans for a linux streamer?

    0
    Comment actions Permalink
  • @Tech,

    As far as I know, there is no plan having an official Linux streamer in short term.

    There is a beta version one: http://www.splashtop.com/linux#download

    0
    Comment actions Permalink
  • Will that work for Splashtop Business as well?

    0
    Comment actions Permalink
  • @Tech,

    You are able to connect to it using Splashtop Business app, but you can't use the deployment code to log in the Linux streamer, only your Splashtop account. Since we did not update it for some time, it might lack some functions.

    0
    Comment actions Permalink
  • Same here i was just informed all my tablets will be moved to linux, and i need a way to deploy splashtop on all our 100's of Kiosk before we can move forward.

    0
    Comment actions Permalink
  • Mike

    Look into SimpleHelp, we switched to it a while ago.

     

    Bruce Davis

     

    1
    Comment actions Permalink
  • 4 years later and no plans for linux.  Thank you Bruce for the recommendation of simple-help  I will definitely be checking them out.   Looks like it could be better than Splashtop, too.

    0
    Comment actions Permalink
  • 5 years later ... still no splashtop business for linux ... :(

    SimpleHelp is no solution for me: It's yearly-subscription-based and expensive too. Rather use RealVNC then

    1
    Comment actions Permalink
  • Please Tell me this is Launching soon!

    1
    Comment actions Permalink
  • Any updates on Splashtop Business on Linux (Ubuntu 20.04 LTS) ?

    3
    Comment actions Permalink
  • april 9 2021... still no splashtop business for Linux... chrome app still hard to use. i dont have any other PC's and my only PC is linux. during pandemic your product is savior but please, you have app for chromebook, why not linux? my middle button dont work with chrome app and im a cad designer... you have no idea how hard it is for me, i might kill myself one day but for now please, at least make windows app WINE compatible

    0
    Comment actions Permalink
  • I've switched to Ubuntu last year and I'm using splashtop for business with wine ( it has some glitches but it can be used fairly well)

    0
    Comment actions Permalink
  • I thought I'd give it a try - looks like my wine doesn't like the installer..  Maybe I'll try the portable

    [code]Unhandled exception: page fault on read access to 0x1000189e in 32-bit code (0x1000189e).
    Register dump:
    CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
    EIP:1000189e ESP:0033fd10 EBP:0042a400 EFLAGS:00010206( R- -- I - -P- )
    EAX:00000001 EBX:00000000 ECX:0033fd28 EDX:00000000
    ESI:00155890 EDI:00429000
    Stack dump:
    0x0033fd10: 0040360f 00000000 00155890 00403628
    0x0033fd20: 00000000 7b465fc0 004035f1 00000002
    0x0033fd30: 0040342d 00000000 7b63d000 0033fed8
    0x0033fd40: 7b63d000 00000000 00000020 00000000
    0x0033fd50: 00429058 00000000 00000000 00000000
    0x0033fd60: 00000000 00000000 00000000 00000000
    Backtrace:
    =>0 0x1000189e EntryPoint+0xffffffff() in system (0x0042a400)
    0x1000189e EntryPoint+0xffffffff in system: addb %al,0x0(%eax)
    Modules:
    Module Address Debug info Name (77 modules)
    PE 370000- 3c0000 Deferred ssuapi
    PE 400000- 43b000 Deferred splashtop_software_updater
    PE 10000000-10006000 Export system
    ELF 7b400000-7b7f8000 Deferred kernel32<elf>
    \-PE 7b420000-7b7f8000 \ kernel32
    ELF 7bc00000-7bd00000 Deferred ntdll<elf>
    \-PE 7bc10000-7bd00000 \ ntdll
    ELF 7c000000-7c004000 Deferred <wine-loader>
    ELF 7d295000-7d2ad000 Deferred userenv<elf>
    \-PE 7d2a0000-7d2ad000 \ userenv
    ELF 7d2ad000-7d2c5000 Deferred wtsapi32<elf>
    \-PE 7d2b0000-7d2c5000 \ wtsapi32
    ELF 7d2c5000-7d323000 Deferred oleacc<elf>
    \-PE 7d2d0000-7d323000 \ oleacc
    ELF 7d323000-7d44c000 Deferred oleaut32<elf>
    \-PE 7d340000-7d44c000 \ oleaut32
    ELF 7d44c000-7d48c000 Deferred winspool<elf>
    \-PE 7d450000-7d48c000 \ winspool
    ELF 7d48c000-7d4a0000 Deferred shfolder<elf>
    \-PE 7d490000-7d4a0000 \ shfolder
    ELF 7d4e6000-7d51e000 Deferred uxtheme<elf>
    \-PE 7d4f0000-7d51e000 \ uxtheme
    ELF 7d51e000-7d52b000 Deferred libxrandr.so.2
    ELF 7d52b000-7d537000 Deferred libxrender.so.1
    ELF 7d537000-7d53e000 Deferred libxxf86vm.so.1
    ELF 7d53e000-7d542000 Deferred libxinerama.so.1
    ELF 7d542000-7d54c000 Deferred librt.so.1
    ELF 7d54c000-7d567000 Deferred libbsd.so.0
    ELF 7d567000-7d56e000 Deferred libxdmcp.so.6
    ELF 7d56e000-7d573000 Deferred libxau.so.6
    ELF 7d573000-7d59f000 Deferred libxcb.so.1
    ELF 7d59f000-7d6e9000 Deferred libx11.so.6
    ELF 7d6e9000-7d6fe000 Deferred libxext.so.6
    ELF 7d700000-7d707000 Deferred libxfixes.so.3
    ELF 7d707000-7d713000 Deferred libxcursor.so.1
    ELF 7d713000-7d726000 Deferred libxi.so.6
    ELF 7d727000-7d7b7000 Deferred winex11<elf>
    \-PE 7d730000-7d7b7000 \ winex11
    ELF 7d928000-7d95a000 Deferred libexpat.so.1
    ELF 7d95a000-7d9a5000 Deferred libfontconfig.so.1
    ELF 7d9a5000-7d9df000 Deferred libpng16.so.16
    ELF 7d9df000-7da9c000 Deferred libfreetype.so.6
    ELF 7da9c000-7dbd9000 Deferred comctl32<elf>
    \-PE 7daa0000-7dbd9000 \ comctl32
    ELF 7dc00000-7dc1f000 Deferred libz.so.1
    ELF 7dc48000-7dc6c000 Deferred imm32<elf>
    \-PE 7dc50000-7dc6c000 \ imm32
    ELF 7dc6c000-7dcb2000 Deferred usp10<elf>
    \-PE 7dc70000-7dcb2000 \ usp10
    ELF 7dcb2000-7dd37000 Deferred rpcrt4<elf>
    \-PE 7dcc0000-7dd37000 \ rpcrt4
    ELF 7dd37000-7de92000 Deferred ole32<elf>
    \-PE 7dd50000-7de92000 \ ole32
    ELF 7de92000-7deb6000 Deferred shcore<elf>
    \-PE 7dea0000-7deb6000 \ shcore
    ELF 7deb6000-7df25000 Deferred shlwapi<elf>
    \-PE 7dec0000-7df25000 \ shlwapi
    ELF 7df25000-7e8e7000 Deferred shell32<elf>
    \-PE 7df30000-7e8e7000 \ shell32
    ELF 7e8e7000-7e960000 Deferred advapi32<elf>
    \-PE 7e8f0000-7e960000 \ advapi32
    ELF 7e960000-7ea8f000 Deferred gdi32<elf>
    \-PE 7e970000-7ea8f000 \ gdi32
    ELF 7ea8f000-7ec98000 Deferred user32<elf>
    \-PE 7eaa0000-7ec98000 \ user32
    ELF 7ec98000-7ecac000 Deferred libnss_files.so.2
    ELF 7ecac000-7ecc7000 Deferred libnsl.so.1
    ELF 7ecc7000-7ecd5000 Deferred libnss_nis.so.2
    ELF 7eed5000-7efd7000 Deferred libm.so.6
    ELF 7efe6000-7f000000 Deferred version<elf>
    \-PE 7eff0000-7f000000 \ version
    ELF f7bd5000-f7bda000 Deferred libdl.so.2
    ELF f7bda000-f7db6000 Deferred libc.so.6
    ELF f7db6000-f7dd6000 Deferred libpthread.so.0
    ELF f7df5000-f7dff000 Deferred libnss_compat.so.2
    ELF f7dff000-f7fb6000 Dwarf libwine.so.1
    ELF f7fb8000-f7fe0000 Deferred ld-linux.so.2
    Threads:
    process tid prio (all id:s are in hex)
    0000000e services.exe
    0000005a 0
    00000020 0
    0000001b 0
    00000013 0
    00000010 0
    0000000f 0
    00000011 winedevice.exe
    00000018 0
    00000017 0
    00000016 0
    00000012 0
    00000019 plugplay.exe
    0000001d 0
    0000001c 0
    0000001a 0
    0000001e winedevice.exe
    00000025 0
    00000022 0
    00000021 0
    0000001f 0
    00000023 explorer.exe
    00000028 0
    00000027 0
    00000026 0
    00000024 0
    00000029 Splashtop_Business_Win_INSTALLER_v3.4.4.0.exe
    0000002a 0
    0000002c cmd.exe
    0000002d 0
    0000002e wineconsole.exe
    0000002f 0
    00000030 PreVerCheck.exe
    00000031 0
    00000032 msiexec.exe
    0000007a 0
    00000039 0
    00000034 0
    00000033 0
    00000035 msiexec.exe
    00000091 0
    00000079 0
    00000052 0
    00000036 0
    00000058 rpcss.exe
    0000008f 0
    00000062 0
    0000005e 0
    0000005d 0
    0000005c 0
    0000005b 0
    00000059 0
    00000090 ISBEW64.exe
    0000008d 0
    0000008e 0
    00000093 0
    00000092 0
    000000e3 (D) C:\users\jem\Temp\{6A4CA92E-2579-4C4D-9C8B-44735449C64E}\Splashtop_Software_Updater.exe
    000000e6 0 <==
    System information:
    Wine build: wine-4.0
    Platform: i386 (WOW64)
    Version: Windows 7
    Host system: Linux
    Host version: 5.4.0-70-generic[/code]

    1
    Comment actions Permalink
  • I'm using wine-6.0

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post