unable to connect to Splashtop streamer

have been using app for a year then a week ago it stopped connecting, the only way I can connect is to switch off wi-fi and hotspot to my iPhone talk talk supplied a new router which did not cure they sent an engineer and he coudnt find problem so looks like I will have to find another way to connect to my work computer

0

Comments

3 comments
  • Obviously this is an old issue, but for anyone experiencing it, the quick & easy route to fixing it is this:

    Any user with a TalkTalk broadband connection will probably be using a TalkTalk-supplied router, which will be hard-set to use TalkTalk's DNS -- which is where they block all remote access packets.

    A different router with configurable DNS settings will work, but it's often easier just to set the DNS addresses on the Mac in System Prefs > Network > Advanced > DNS. You can use the Google addresses (8.8.8.8 & 8.8.4.4) or any others such as DNSWatch -- these will override the router's settings.

    This is massively easier and less frustrating than interacting with TalkTalk on any level.

    1
    Comment actions Permalink
  • @Rod,

    We are aware of that TalkTalk provides a service that will block Splashtop service by default, can you contact TalkTalk regarding the issue, and have them whitelist our servers in the service, it then should work.

    Thanks,
    Vans

    0
    Comment actions Permalink
  • This was a life saver and fully agree. Now working from home and they were blocking this

    Thank you!

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post