Macs connected via TalkTalk (UK) — fix non-connection with 10.14.x and up

As previously noted, TalkTalk (UK) broadband users will very often be using TalkTalk routers, in which the DNS servers used cannot be changed. Because the router is hard-set to use TalkTalk's own DNS servers, remote access data is blocked, and Splashtop Streamer will not activate properly (deployment codes won't work).

Setting the DNS servers used by an individual Mac will however override the router's DNS setting, and in the past this has been simple:

System Preferences > Network > Unlock (enter user password) > [choose network connection] > Advanced > DNS > [+ button] > enter new DNS server addresses > Close > Apply.

Starting with 10.14 (Mojave), there is no lock apparent on network settings, and the DNS address list referred to above is shown greyed out, giving the impression that it's not editable — wrong. Screenshot that list if you want it for reference, then:

Just use the '+' button as before, and add your new DNS servers. In a complete reversal of previous macOS UI convention, they will replace the greyed-out list. Exit and 'Apply' when prompted, and suddenly Splashtop Streamer will be able to reach the internet.

Just spent 2 days finding this out. Hopefully this will save other users the same angst.




Please sign in to leave a comment.

Didn't find what you were looking for?

New post