Impossible d'atteindre le serveur (streamer) en raison de la désactivation du support TLS 1.0

S’abonner

Scénario TLS

Pour se mettre en conformité avec la norme PCI, certains utilisateurs pourraient utiliser l'outil (comme IISCrypto) pour n'autoriser que le trafic TLS 1.1 et 1.2 en désactivant la prise en charge de TLS 1.0 sur leurs ordinateurs. Dans un tel cas, vous pourriez rencontrer l'impossibilité d'atteindre l'erreur de serveur sur les ordinateurs Windows 7 et Server 2008. Le réglage par défaut pour ces versions de systèmes d'exploitation est TLS 1.0.

 

Comment activer TLS 1.1 ?

1. Enregistrer TLS 1.1

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
"Enabled"=dword:ffffffff"DisabledByDefault"
=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
"Enabled"=dword:ffffffff "DisabledByDefault
"

=dword:00000000

2. Configurer TLS 1.1 pour qu'il soit utilisé par défaut pour WinHTTP

Pour Windows 7/Serveur 32 bits 2008

[HKEY_LOCAL_MACHINE_SOFTWARE_Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp]
"DefaultSecureProtocols"=dword:00000200

Pour Windows 7/Serveur 64 bits 2008

[HKEY_LOCAL_MACHINE_SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp]
"DefaultSecureProtocols"=dword:00000200

3. Pour le TLS 1.2, utilisez dword:00000800, à la place pour l'étape 2

Note :

Windows XP utilise SSL v3 par défaut pour WinHTTP. Windows 8 ou supérieur utilise TLS 1.1 pour WinHTTP par défaut.

Article de référence :

Support Microsoft

Utilisateurs qui ont trouvé cela utile : 0 sur 1