Splashtop Business App on Debian

I'm using Debian Sid (Bullseye 11 should be the same), but I ran into an issue installing the app.  It specifically was looking for Ubuntu versions, which caused the final step of linking the binary from the installation folder to /usr/bin.  

So far, simply linking the binary manually appears to be working.  

1

Commenti

8 commenti
  • Hi, I'm having the same problem. How did you fix it? 

    0
  • Have you tried this?

    wget https://download.splashtop.com/linux/STB_CSRS_Ubuntu_v3.5.0.0_amd64.tar.gz

    tar -xvf STB...

    apt install ./Splashtop_Streamer_Ubuntu_amd64.deb

    splashtop-streamer deploy

    enter your deployment code

    0
  • Hi, thanks for the reply. 

    I thought i could only use the splashtop business program, as that's the version I picked. 

    I tried the splashtop streamer you posted and still could not get it to work. 

    I ran the install command and this was the output. 

     

    root@mx3900x:/home/user/Downloads/STB_CSRS_Ubuntu_v3.5.0.0_amd64# apt install ./Splashtop_Streamer_Ubuntu_amd64.deb
     
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Note, selecting 'splashtop-streamer' instead of './Splashtop_Streamer_Ubuntu_amd64.deb'
    The following packages were automatically installed and are no longer required:
      libminiupnpc17 libnatpmp1 python-pip-whl python3-pip python3-wheel
    Use 'apt autoremove' to remove them.
    The following additional packages will be installed:
      libproxy-tools libproxy1-plugin-gsettings liburiparser1
    Suggested packages:
      libproxy1-plugin-kconfig
    Recommended packages:
      libproxy1-plugin-mozjs libproxy1-plugin-webkit libproxy1-plugin-networkmanager
    The following NEW packages will be installed:
      libproxy-tools libproxy1-plugin-gsettings liburiparser1 splashtop-streamer
    0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 91.9 kB/3,976 kB of archives.
    After this operation, 16.0 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 /home/user/Downloads/STB_CSRS_Ubuntu_v3.5.0.0_amd64/Splashtop_Streamer_Ubuntu_amd64.deb splashtop-streamer amd64 3.5.0.0-1 [3,884 kB]
    Get:2 http://debian.gtisc.gatech.edu/debian bullseye/main amd64 libproxy-tools amd64 0.4.17-1 [16.2 kB]
    Get:3 http://debian.gtisc.gatech.edu/debian bullseye/main amd64 libproxy1-plugin-gsettings amd64 0.4.17-1 [29.7 kB]
    Get:4 http://debian.gtisc.gatech.edu/debian bullseye/main amd64 liburiparser1 amd64 0.9.4+dfsg-1+deb11u1 [45.9 kB]
    Fetched 91.9 kB in 0s (253 kB/s)        
    Selecting previously unselected package libproxy-tools.
    (Reading database ... 397733 files and directories currently installed.)
    Preparing to unpack .../libproxy-tools_0.4.17-1_amd64.deb ...
    Unpacking libproxy-tools (0.4.17-1) ...
    Selecting previously unselected package libproxy1-plugin-gsettings:amd64.
    Preparing to unpack .../libproxy1-plugin-gsettings_0.4.17-1_amd64.deb ...
    Unpacking libproxy1-plugin-gsettings:amd64 (0.4.17-1) ...
    Selecting previously unselected package liburiparser1:amd64.
    Preparing to unpack .../liburiparser1_0.9.4+dfsg-1+deb11u1_amd64.deb ...
    Unpacking liburiparser1:amd64 (0.9.4+dfsg-1+deb11u1) ...
    Selecting previously unselected package splashtop-streamer.
    Preparing to unpack .../Splashtop_Streamer_Ubuntu_amd64.deb ...
    [Splashtop-Streamer] Install streamer
    Unpacking splashtop-streamer (3.5.0.0-1) ...
    Setting up libproxy1-plugin-gsettings:amd64 (0.4.17-1) ...
    Setting up liburiparser1:amd64 (0.9.4+dfsg-1+deb11u1) ...
    Setting up libproxy-tools (0.4.17-1) ...
    Setting up splashtop-streamer (3.5.0.0-1) ...
    [Splashtop-Streamer] Configure streamer
    [Splashtop-Streamer] Install user binary link
    [Splashtop-Streamer] Install streamer service
    [Splashtop-Streamer] Start streamer service
    System has not been booted with systemd as init system (PID 1). Can't operate.
    Failed to connect to bus: Host is down
    dpkg: error processing package splashtop-streamer (--configure):
     installed splashtop-streamer package post-installation script subprocess returned error exit status 1
    Processing triggers for desktop-file-utils (0.26-1) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for libc-bin (2.31-13+deb11u4) ...
    Processing triggers for man-db (2.9.4-2) ...
    Processing triggers for dbus (1.12.20-2) ...
    Processing triggers for mailcap (3.69) ...
    Errors were encountered while processing:
     splashtop-streamer
    E: Sub-process /usr/bin/dpkg returned an error code (1)

     

     

    The deploy command, i put my real code in. 

    root@mx3900x:/home/user/Downloads/STB_CSRS_Ubuntu_v3.5.0.0_amd64# splashtop-streamer deploy
     
     
    Streamer Deployment
      splashtop-streamer deploy [CODE]
      Enter code from your admin to allow access to this computer.
      Code: XXXXXXXXXXXXXXX
    System has not been booted with systemd as init system (PID 1). Can't operate.
    Failed to connect to bus: Host is down
      Deploy Success
    System has not been booted with systemd as init system (PID 1). Can't operate.
    Failed to connect to bus: Host is down

     

    I tried launching the program. It tried to load but closes.

     

    0
  • Can you do a:

    lsb_release -a

    And post the output?

    I will try installing Splashtop Streamer on Debian and see if it works.

    0
  • I was able to get the business streamer to work by doing this. 

    Link the binary from the installation folder " /opt/spalshtop-business" to /usr/bin. 

     

    Now, i have a new problem, the program launches but the screen is shifted funny, only uses 1/3 of the screen and the mouse cursor is shifted by a few inches. 

     

    Lastly, i dont see any options for multimonitor, file transfer, and copy and paste support. Does the linux version not support these features?

    0
  • This is the version of linux that im running 
    https://sourceforge.net/projects/mx-linux/files/Final/Xfce/MX-21.2.1_ahs_x64.iso/download

     

    root@mx3900x:/opt/splashtop-streamer# dmesg | grep Linux
    [    0.000000] Linux version 5.18.0-4mx-amd64 (stevep@mxlinux.org) (gcc-10 (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP PREEMPT_DYNAMIC Debian 5.18.16-1~mx21+1 (2022-08-22)
    [    0.374861] TOMOYO Linux initialized
    [    0.539967] ACPI: Added _OSI(Linux-Dell-Video)
    [    0.539967] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
    [    0.539967] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
    [    0.546199] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    [    1.564243] Linux agpgart interface v0.103
    [    1.851245] pps_core: LinuxPPS API ver. 1 registered
    [    1.864002] usb usb1: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [    1.864664] usb usb2: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [    1.865640] usb usb3: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [    1.866099] usb usb4: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [    1.866856] usb usb5: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [    1.867050] usb usb6: Manufacturer: Linux 5.18.0-4mx-amd64 xhci-hcd
    [   46.004102] Intel(R) Wireless WiFi driver for Linux
    [   47.055280] mc: Linux media interface: v0.10

     

    root@mx3900x:/opt/splashtop-streamer# lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description:    Debian GNU/Linux 11 (bullseye)
    Release:        11
    Codename:       bullseye

    0
  • I found debian to be problematic also. Suggest you try using Ubuntu 20.04 LTS 22.04 Jammy does not work properly right now.

    0
  • Thanks for the reply, Thomas. Do you know if from an ubuntu client, i can control a windows 10 machine with these features? Multimonitor, file transfer, and copy and paste support. 

    0

Accedi per aggiungere un commento.

Non hai trovato quello che cercavi?

Nuovo post