Tip: Windows 11 "User always Active" bug fix

Back last Spring 2022 I upgraded a couple of computers up to Windows 11 through Windows Update. Very smooth upgrade and I did it remotely through Splashtop. It worked very well and fairly fast.

I did notice one problem though.  Splashtop Streamer from then on always showed the user as "User Activity: Active" in Splashtop Business.  That's a problem for me to be able to effectively support my users; I need to know if I can work on the computer.  I contacted support in June and within a few days they got back to me with a registry change on the Windows 11 computers.  I applied the change and then restarted the Streamer. It worked.

Now it's been four months and upgrades have come down for the Splashtop Streamer, but this simple registry entry has not been included in the updates which is strange. So, here it is...

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Splashtop Inc.\Splashtop Remote Server

Registry key: UserIdleMethod

Registry type: REG_DWORD

Registry value: 1


I decided I waited long enough and manually editing registries in way to labor intensive on remote computers.    So here is the line of code that I use in Splashtop's 1-to-Many Actions to deploy the change to Windows 11 computers remotely.

REG ADD "HKLM\Software\WOW6432Node\Splashtop Inc.\Splashtop Remote Server" /v UserIdleMethod /t REG_DWORD /d 1

Net Stop SplashtopRemoteService

Net Start SplashtopRemoteService

 

If you didn't remote into the computer to be "Active" on it and the User has been inactive, Splashtop Business will show how long they've been away even from before you applied the registry change.

Hopefully soon we won't have to add this registry change manually after Splashtop pushes out this change in a future Streamer update.
 

 

1

Commenti

0 commenti

Accedi per aggiungere un commento.

Non hai trovato quello che cercavi?

Nuovo post